896426745
05.05.2022 01:08

Составьте программу, которая запрашивает число. Если введено положительное число, то на экран выводится квадрат этого числа. В противном случае выводится сообщение "Ошибка. Введено неправильное число" и повторный запрос на ввод нового числа.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
kate832
09.11.2021 13:30

Программа:

Python:

while True:

   n = int(input('Введите число: '))

   if n > 0:

       print(n * n)

       break

   else:

       print('Ошибка. Введено неправильное число')

Pascal:

var

 n: integer;

begin

 while True do begin

   write('n = '); readln(n);

   if n > 0 then begin

     writeln(n * n);

     break

   end

   else writeln('Ошибка. Введено неправильное число');

 end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота