NastyuZnanija
15.01.2022 10:32

Напиши программу, которая разделяет запятыми на тройки (считая справа) натуральное число. Программа на вход получает натуральное число.

Если в числе менее трёх знаков, то программы выводи текст: нет.

Пример работы программы.

Входные данные: 23109

Выходные данные: 23,109

Входные данные: 312

Выходные данные: нет

программа: Пайтон

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
amina24569
23.06.2022 20:56
Var a, b: integer;
var c: string;
begin
writeln('Введите 1 число.');
readln(a);
writeln('Введите 2 число.');
readln(b);
writeln('Знак операции.');
readln(c);
if c='*' then writeln(a*b);
if c='/' then writeln(a/b);
if c='-' then writeln(a-b);
if c='+' then writeln(a+b);
end.
2 ЗАДАЧА 
var a, b: real;
begin
writeln('Зарабаток Пети:');
readln(a);
writeln('Зарабаток Петрова:');
readln(b);
if a>b then writeln('Петя заработал больше Петрова.')
else if a=b then writeln('Петров и Петя заработали одинаково.')
else
writeln('Петров заработал больше Пети.');
writeln('Среднее: ', (a+b)/2);
end.
0,0(0 оценок)
Ответ:
lol1027
28.07.2021 05:33
Не самый рациональный метод решения, но как говорится чем смог тем

var a,b,c,x,kc,kn,k1,k2:integer; 
begin 
kc:=1; 
kn:=1; 
k1:=0; 
k2:=0; 
a:=0; 
b:=0; 
writeln('Введите число x'); 
read(x); 
while x>0 do begin 
c:=x mod 10; 
if c mod 2=0 then begin 
inc(k1); 
a:=a+c*kc; 
kc:=kc*10; 
end; 
if c mod 2<>0 then begin 
inc(k2); 
b:=b+c*kn; 
kn:=kn*10; 
end; 
x:=x div 10; 
end; 
if k1>k2 then writeln('Четных больше нечетных') else if k1=k2 then writeln('Количество четных = количеству нечетных') else writeln('Четных меньше нечетных'); 
writeln(a,' ', b); 
end. 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота