JEJH
04.03.2023 10:10

4. Составить программу, которая формирует массив из 30 случайных целых чисел от -10 до 10, выводит его на экран и вычисляет сумму чисел, не превышающих 5.
Сохранить в файле Обобщение4.pas

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Gпчелкажужу
26.04.2020 11:42

from random import randint

S1 = [randint(1,100) for i in range(20)]

summa1 = 0

summa2 = 0

for i in S1:

   if i % 2 == 0:

       summa1 += i

   else:

       summa2 += i

print(f"Сумма чётных = {summa1}")

print(f"Сумма нечёт = {summa2}")

print(max(S1)) # Значение наибольшего элемента в массиве

print(min(S1)) # Значение наименьшего элемента в массиве

summa = 0

for i in S1:

   if i < 30:

       summa += i

print(f"Сумма чисел меньше 30-ти = {summa}")

summa = S1[2]

for i in S1:

   summa *= i

print(f"Произведение элементов с индексов 2({S1[2]}) = {summa}")


Задайте одномерный массив, содержащий 20 элементов, взятых случайным образом из интервала [1, 100].В
0,0(0 оценок)
Ответ:
StrongA11
09.06.2022 09:22
Const
  n = 40;

var
  x: array[1..n] of integer;
  i, k, s: integer;

begin
  Randomize;
  Writeln('Элементы массива');
  k := 0; s := 0;
  for i := 1 to n do
  begin
    x[i] := Random(50);
    Write(x[i]:3);
  end;
  Writeln;
  Writeln('Элементы со значением в интервале [7;10]');
  for i := 1 to n do
    if (x[i] >= 7) and (x[i] <= 10) then
    begin
      k := k + 1; s := s + x[i];
      Write(x[i]:3)
    end;
  if k = 0 then Writeln('не найдены')
  else Writeln(#13#10, ' Элементов:', k, ', среднее арифметическое=', s / k:5:3)
end.

Тестовое решение:

Элементы массива
 24 33 36 29 12  7  5 36  3 48 40 40 46  6 10 23 33  3 38 48 29 37 11 40 44 16 17 18 34 38 33 39  9  0 41 37 42  2 40 31
Элементы со значением в интервале [7;10]
  7 10  9
 Элементов:3, среднее арифметическое=8.667
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота