карина2333
11.05.2021 17:47

3. написать программу, определяющую, лежит ли точка с указанными координатами а (x, y) на окружности радиуса r с центром в начале координат (может лежать на окружности, внутри окружности, вне окружности) ps: pascal(не турбо) всем буду !

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Бодичка539
25.06.2020 09:13
Var
x,y, r: Iinteger;
Begin
Write('Введите координату X: ');
Readln(x);
Write('Введите координату Y: ');
Readln(y);
Write('Введите длину радиуса R: ');
Readln®;
If (sqr(x)+sqr(y))=r then writeln('Точка лежит на окружности!')
Else writeln('Точка не лежит на окружности!');
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота