dxkuznecov
19.12.2021 03:46

Данные действительные числа s,t. Напишите программу вычисления выражения f(t,-2s, 1.17)+f(2.2, t, s-t), где f(a, b, c) = (2a – b – sin (c)) / (5+|c|).

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
рррр194
03.03.2020 21:53

для задач необходимо подключить библиотеку cmath, задачи решены на с++, надеюсь решения тебе

Объяснение:

a)    int a, b, c, d; // a меньшее основание б большее . с д - боковые стороны

   cin >> a >> b >> c >> d;

   cout << a+b+c+d << endl;// периметр

   cout << sqrt(c*c-((b-a)/2)*((b-a)/2))*(a+b)/2; // площадь

   return 0;

b)   int x1,y1, x2,y2;

   cin >> x1 >> y1 >> x2 >> y2;

   cout << sqrt((x2-x1)*(x2-x1)+(y2-y1)*(y2-y1));

   return 0;

c)int  x2,y2;

   cin >>  x2 >> y2;

if ( sqrt((x2-0)*(x2-0)+(y2-0)*(y2-0))>7)

cout << "YES";

else cout << "NO";

   return 0;

d)int  a[10],c=0;

   for(int i=0; i<10;i++)

      {cin >> a[i];

      c+=abs(a[i]);}

      cout << c/10;

return 0;

0,0(0 оценок)
Ответ:
NASTIAMURKA
23.09.2022 13:46

графическая или изобразительная

звуковая (акустическая)

текстовая

числовая

видеоинформация

Обьяснение:

Основные виды информации по её форме представления её кодирования и хранения, что имеет наибольшее значение для информатики, это:

графическая или изобразительная — первый вид, для которого был реализован хранения информации об окружающем мире в виде наскальных рисунков, а позднее в виде картин, фотографий, схем, чертежей на бумаге, холсте, мраморе и др. материалах, изображающих картины реального мира;

звуковая (акустическая) — мир вокруг нас полон звуков и задача их хранения и тиражирования была решена с изобретением звукозаписывающих устройств в 1877 г. (см., например, историю звукозаписи на сайте — её разновидностью является музыкальная информация — для этого вида был изобретен кодирования с использованием специальных символов, что делает возможным хранение её аналогично графической информации;

текстовая кодирования речи человека специальными символами — буквами, причем разные народы имеют разные языки и используют различные наборы букв для отображения речи; особенно большое значение этот приобрел после изобретения бумаги и книгопечатания;

числовая — количественная мера объектов и их свойств в окружающем мире; особенно большое значение приобрела с развитием торговли, экономики и денежного обмена; аналогично текстовой информации для её отображения используется метод кодирования специальными символами — цифрами, причем системы кодирования (счисления) могут быть разными;

видеоинформация сохранения «живых» картин окружающего мира, появившийся с изобретением кино.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота