dimanichaev799
05.10.2021 22:32

Напишите программу, в которой необходимо организовать ввод многомерного списка (можно использовать рандомное заполнение) и выполнение действий с ним согласно своему варианту.
Для реализации программы используйте функции.
ЗАДАНИЕ:
Введите многомерный список, состоящий из целых чисел, количество элементов
определяет пользователь. Запросите у пользователя ввести номера двух строк и поменяйте
эти строки местами.
Используйте функции для ввода и вывода многомерного списка и для замены строк.
Python

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Эвелина2019
11.01.2022 00:05

import random

n, m = map(int, input().split())

a = list()

for i in range(n):

   u = list()

   for j in range(m):

       u.append(random.randint(1,1000))

   a.append(u)

k, l = map(int, input().split())

print("before changing: ")

for i in range(n):

   print(*a[i], sep=" ")

for i in range(m):

   t = a[k-1][i]

   a[k-1][i] = a[l-1][i]

   a[l-1][i] = t

print("after changing: ")

for i in range(n):

   print(*a[i], sep=" ")

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота