kotma19
15.07.2021 16:27

1.На входе программы есть два целых числа, каждое в отдельной строке. На выход нужно подать сумму заданных чисел.
Входные данные
Два целых числа, записанных в столбик.
Выходные данные
Сумма заданных чисел.
Примеры
Ниже вы найдете примеры входных данных и ответов, которые должна вывести ваша программа.
12
9
ответ №1
21
2. Вам дано ціле число n. Також є три види операцій:
Зменшити n на 1.
Збільшити n на 1.
Якщо n ділиться націло на 3, поділити n на 3.
За яку мінімальну кількість операцій можна зробити число n рівним 1?
Входные данные
Перший рядок містить одне ціле число n (1≤n≤1018).
Выходные данные
Виведіть одне число — мінімальну кількість операцій, за яку можна зробити число n рівним 1.
Заметка
У першому прикладі можна один раз поділити на 3 і отримаємо 1.
У другому прикладі можна спочатку двічі зменшити n на 1, а потім поділити на 3.
Оценивание
Рішення, які працюють правильно для обмежень 1≤n≤105, набиратимуть 40% балів.
Примеры
Ниже вы найдете примеры входных данных и ответов, которые должна вывести ваша программа.
Входные данные №1
3
ответ №1
1
Входные данные №2
5
ответ №2
3
Входные данные №5
70109
ответ №5
18

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
svetik83
21.12.2021 09:09
1. Вот так это пишется с функцией

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
function IsPrime(n:integer):boolean;
begin
  if n<4 then Result:=True
  else begin
    var found:= (n mod 2 = 0);
    var p:=3;
    while (not found) and (sqr(p)<=n) do
      begin
      found:=(n mod p = 0);
      p+=2
      end;
    Result:=not found
    end
end;

begin
  Writeln('k=',ArrRandom(ReadInteger('n='),1,999).Println.
    Where(x->IsPrime(x)).Count)
end.

Тестовое решение:
n= 10
401 828 780 444 694 965 23 341 673 875
k=3

2. А вот так это пишется с процедурой

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
procedure IsPrime(n:integer; var res:boolean);
begin
  if n<4 then res:=True
  else begin
    var found:= (n mod 2 = 0);
    var p:=3;
    while (not found) and (sqr(p)<=n) do
      begin
      found:=(n mod p = 0);
      p+=2
      end;
    res:=not found
    end
end;

begin
  var a:=ArrRandom(ReadInteger('n='),1,999); a.Println;
  var k:=0;
  var prime:boolean;
  foreach var e in a do begin
    IsPrime(e,prime);
    if Prime then Inc(k)
    end;
  Writeln('k=',k)
end.

Тестовое решение:
n= 12
199 43 71 365 417 904 170 212 694 103 161 689
k=4
0,0(0 оценок)
Ответ:
KrystallBlack
10.10.2020 19:01
// тестировалось на C#.Net Framework 4.5
using System;

class Program
{
    static void Main()
    {
        int x1 = 2, y1 = 1;
        int x2 = 6, y2 = 5;
        int x3 = 10, y3 = 1;

        var a = Distance(x2, y2, x3, y3);
        var b = Distance(x1, y1, x3, y3);
        var c = Distance(x2, y2, x1, y1);

       
        Console.WriteLine("S = {0}", Square(a, b, c));
        Console.ReadKey();
    }

    //растояние между точками
    static double Distance(int x1, int y1, int x2, int y2)
    {
        return Math.Sqrt((x2 - x1) * (x2 - x1) + (y2 - y1) * (y2 - y1));
    }

    //формула герона
    static double Square(double a, double b, double c)
    {
        var p = (a + b + c) / 2;
        return Math.Sqrt(p * (p - a) * (p - b) * (p - c));
    }

    // теорема косинусов
    static double Angle(double a, double b, double c)
    {
        return Math.Acos((b * b + c * c - a * a) / (2 * b * c));
    }

    static bool IsAcuteAngel(double alpha)
    {
        return alpha < Math.PI / 2;
    }
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота