UnknownKnowns
05.05.2022 03:14

Напишите программу, которая проверяет, является ли матрица стохастической. На вход программы подается два натуральных числа, N и M, через пробел, далее N строк по M вещественных чисел через пробел - значения вашей матрицы. Нужно напечатать “стохастическая” или “не стохастическая” .

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
хитМо
10.03.2023 09:29
Задание 1integerВещественные числаДля объявления переменныхWritelnЗадание 2

На третьей строчке, видимо, ошибка, и вместо Вывод(x) на самом деле Ввод(x).

var  x: integer;  y: real; begin  Readln(x);  y := (10 + 2 * x) / (11 - x);  Writeln(y); end.При x = 3 переменная y = 2Задание 3var  number, resultNumber, i: integer; begin  resultNumber := 1;  for i := 1 to 3 do    begin      Readln(number);      resultNumber := resultNumber * number;    end;  Writeln(resultNumber); end.Задание 4var  a: integer;  b, c: real; begin  a := 3;  b := -1.5;  c := 6 - 2 * b;  c := c - a;  Writeln(c); end.Результатом вывода будет число 6Задание 5var  x, y, z: integer; begin  x := 8;  y := 2;  if (x > y) then    z := x - y  else    z := y + x;  Writeln(z); end.
0,0(0 оценок)
Ответ:
lagoshinanatal
23.06.2021 19:52

26

Объяснение:

a = 23 (дано число a)

выполняем цикл (увеличиваем число a на 5 и проверяем условие число a больше 35, если условие истинно (да) выходим из цикла, если ложное (нет), то повторяем цикл)

a = a + 5 = 23 + 5 = 28

a > 35 (28 > 35, нет)

a = a + 5 = 28 + 5 = 33

a > 35 (33 > 35, нет)

a = a + 5 = 33 + 5 = 38

a > 35 (38 > 35, да)

a = a * 2 =  38 * 2 = 76 (увеличиваем число a в 2 раза)

проверяем условие является ли число a двузначным, если условие истинно (да), то выполняем левую ветку, а правую ветку (ещё один цикл) не трогаем (если условие ложно (нет), то выполняем правую ветку (ещё один цикл), а левую ветку не трогаем)

9 < a < 100 (9 < 76 < 100, да - двузначное)

a = a - 50 = 76 - 50 = 26 (уменьшаем число a на 50)

получаем ответ (больше ничего не делаем)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота