krisa2003p08dzp
22.05.2021 19:43

написать программу на C++ функции Функция: количество нулевых значений среди координат
Для векторов v1, v2, v3 найти количество нулевых координат. Сформировать один новый вектор, в который занести все ненулевые координаты из векторов в следующей последовательности: координаты из вектора, имеющего наибольшее количество нулевых значений, за ними координаты вектора со вторым количеством нулевых значений, наконец – координаты вектора с наименьшим количеством нулевых значений. Вывести количество нулевых координат в векторах, сформирован новый вектор.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Asya0199
29.10.2022 08:56

// Привет дедам

const M = 5;

const N = 12;

var matrix: array [1..M, 1..n] of integer;

var i, j, count: integer;

begin

   for i := 1 to M do

   begin

       for j := 1 to N do

       begin

           matrix[i, j] := random(-98, 54);

           write(matrix[i, j]:4);

       end;

       writeln();

   end;

   

   writeln();

   writeln('Кол-во четных элементов: ');

   for j := 1 to N do

   begin

       count := 0;

       for i := 1 to M do

       begin

           if matrix[i, j] mod 2 = 0 then

               inc(count);

       end;

       write(count:4);

   end;

end.

0,0(0 оценок)
Ответ:
frankinshtein228
09.03.2023 12:45

192 символа на страницу - итого 30720 символов на весь текст. Мощность алфавита 256 - значит в алвавите 256 знаков. 2 в степени восемь - равно 256 (от 0 до 255). Т. е. весь алфавит можно закодировать одним байтом (в одном байте - как раз восемь бит, степень двойки. Бит - принимает ДВА значения - 0 и 1 - отсюда основание 2, которое возводим в восемь :) ) на каждый символ текста надо потратить один байт памяти. Итого получаем 30720 БАЙТ. в одном КИЛОБАЙТЕ 1024 байта. Делим 30720 на 1024 получаем 30 КБайт.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота