Словарь11
05.09.2022 19:27

PYTHON, информатика 9 класс


PYTHON, информатика 9 класс

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ПОМОГИТЕ13217
22.01.2022 07:53

Программа:

Python:

1. Напишите программу, которая на вход получает 50 случайных чисел и находит в массиве количество элементов, делящихся на 7.

from random import randint

arr = [randint(-50,50) for i in range(50)]

j = 0

for i in arr:

  if i % 7 == 3:

     j += 1

print(arr, '\n', j, 'чисел делится на 7')

2. Написать программу, которая на вход получает 50 случайных чисел и находит среднее арифметическое всех элементов массива, которые делятся на 2 и заканчиваются на 2.

from random import randint

arr = [randint(-50,50) for i in range(50)]

j = k = 0

for i in arr:

  if i % 10 == 2 and i % 2 == 0:

     j += i

     k += 1

print(arr, '\nСреднее арифметическое чисел, которые делятся на 2 и заканчиваются на 2:', j / k)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота