dazacyhko
03.07.2021 20:51

написать программу в которой: вводится и выводится массив из 10 рандомных чисел (от - 10 до 10). Нужно найти сумму элементов массива и максимальное значение. Вывести ответы на экран.(через паскаль)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
СоняКот2000
31.01.2022 08:57

program test;

var i,s,m:integer;

a:array [1..10] of integer;

begin

randomize;

s:=0;  

for i:=1 to 10 do

begin

a[i]:=random(21)-10;

write(a[i],' ');

s:=s+a[i];

if i=1 then m:=a[i]

else if a[i]>m then m:=a[i]

end;

writeln;

writeln(s);

writeln(m)

end.

0,0(0 оценок)
Ответ:
rast2k17
31.01.2022 08:57

Программа:

Pascal:

var arr: array[1..10] of integer;

begin

 for var i := 1 to 10 do arr[i] := random(-10, 10);

 writeln('Массив: ', arr);

 writeln('Сумма элементов массива: ', arr.sum);

 writeln('Максимальный элемент массива: ', arr.max);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота