anechka50
17.09.2021 04:53

Паскаль Задача 3. Ремонт забора Имя входного файла: стандартный ввод
Имя выходного файла: стандартный вывод
Ограничение по времени: 1 секунда
Ограничение по памяти: 512 мегабайт
Забор состоит из N одинаковых вертикальных досок. Некоторые из досок сгнили и нуждаются в
замене, для каждой доски известно, нужно ли её заменить. Для ремонта забора можно использовать
продающиеся в магазине щиты, которые бывают L разных видов: шириной в 1 доску, в 2 доски, ...,
в L досок. Щит нельзя разрезать на части, то есть одним щитом можно заменить не более любых
L подряд идущих досок. При этом можно менять не только сгнившие доски, но и хорошие.
Оказалось, что все щиты стоят одинаково, независимо от размера щита. Определите, какое наименьшее число щитов необходимо приобрести, чтобы починить весь забор.
Формат входных данных
Первая строка входных данных содержит целое число L (L > 0) — максимальный размер щита.
Во второй строке входных данных записано целое число N (N > 0) — количество досок в заборе.
Следующие N строк содержат по одному числу, равному 0 или 1. Число 1 обозначает, что соответствующая доска в заборе нуждается в замене, число 0 — что доска может быть сохранена.
Формат выходных данных
Программа должна вывести одно целое число — минимальное число щитов, которое необходимо
приобрести для ремонта всего забора.
Система оценивания
Решение, правильно работающее только для случаев, когда числа L и N не превосходят 1000,
будет оцениваться в
В будет оцениваться решение, правильно работающее, когда числа L и N не превосходят 105
.
Пример
стандартный ввод стандартный вывод
3
8
0
0
1
0
1
0
1
0
3
Пояснение к примеру
Максимальная ширина одного щита равна 3. Забор состоит из 8 досок, нужно заменить доски
с номерами 3, 5 и 7. Для этого достаточно двух щитов, например, одним щитом меняем доски с
номерами 3, 4, 5, а другим щитом меняем доску с номером 7

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
millykot2003
01.06.2020 09:14

С одной стороны, электронные страницы – это хорошо, меньше вреда наносится окружающей среде, да и хранить большое количество информации легче и удобнее в электронном виде. С другой стороны – человечество становится все более зависимым от техники.  Многие даже представить себе не могут, что будут делать,  если, например, забудут дома телефон, это приравнивается к трагедии. Велико число тех, кто  просто убивает время в социальных сетях, живое общение заменяется  набором букв на компьютере, а жесты и мимика  –  смайликами. Да, это хорошо для тех, кто находится далеко друг от друга, или в силу каких – то других причин просто физически не могут увидеться. Но мы злоупотребляем такими благами, так как, живя по соседству – общаемся посредством сети и устройств. Люди просто перестали ходить в гости и просто видеться. То, насколько мы будем зависимы от компьютера – определяем мы сами. Человек сам определяет, на что тратить время, как проживать жизнь. И если использовать ИТ и другие блага только в полезных целях  и в меру – жить станет легче не только нам, но и будущим поколениям, и им не придется страдать от нашей невнимательности и лени.

Объяснение:

0,0(0 оценок)
Ответ:
polinavorkuta
13.12.2021 16:36

ответ (перепроверьте на всякий случай скобки, вроде должно быть всё верно, но там довольно замороченно, лучше ещё раз перепроверить):

from math import atan,log

a = [0.5, -1, -2]

b = [1.5, 0.5, 0]

p = [-4, -4, -4]

while True:

 try:

   x = float(input('Введите x: '))

   break

 except ValueError:

   print('Вводите число!')

if abs(x) < 0.2:

 for i in range(3):

   print(f'Вариант {i+1}: {a[i]**2 * x**3 + (b[i]**4 + 1.7)**0.5}')

elif abs(x) == 0.2:

 for i in range(3):

   print(f'Вариант {i+1}: {atan(2**x - abs(p[i]))}')

else:

 for i in range(3):

   print(f'Вариант {i+1}: {(log(abs(a[i])) + 4.3)**(1/3) + x}')

"Попроще" - без циклов, проверки ввода и массивов:

from math import atan,log

a1 = 0.5

a2 = -1

a3 = -2

b1 = 1.5

b2 = 0.5

b3 = 0

p1 = -4

p2 = -4

p3 = -4

x = float(input('Введите x: '))

if abs(x) < 0.2:

 y = a1**2 * x**3 + (b1**4 + 1.7)**0.5

 print('Вариант 1: ', y)

 y = a2**2 * x**3 + (b2**4 + 1.7)**0.5

 print('Вариант 2: ', y)

 y = a3**2 * x**3 + (b3**4 + 1.7)**0.5

 print('Вариант 3: ', y)

elif abs(x) == 0.2:

 y = atan(2**x - abs(p1))

 print('Вариант 1: ', y)

 y = atan(2**x - abs(p2))

 print('Вариант 2: ', y)

 y = atan(2**x - abs(p3))

 print('Вариант 3: ', y)

else:

 y = (log(abs(a1)) + 4.3)**(1/3) + x

 print('Вариант 1: ', y)

 y = (log(abs(a2)) + 4.3)**(1/3) + x

 print('Вариант 2: ', y)

 y = (log(abs(a3)) + 4.3)**(1/3) + x

 print('Вариант 3: ', y)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота