Arinka722
05.08.2020 04:30

Pascal ! 1. составьте программу, вычисляющую, сколько букв надо исправить в слове х, чтобы получилось слово y (слова x и y одинаковой длины). 2. составьте программу, определения номера первой буквы "а" в слове х. 3. составьте программу, позволяющую выяснить, первая или последняя буква слова встречается в слове х чаще.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
valeriargavina
25.06.2020 21:48
Задача 1.
var
  i,c: integer;
  x,y: string;

begin
  readln(x);
  readln(y);
  for i:=1 to length(x) do
    if x[i]<>y[i] then inc(c);
  writeln('Букв надо исправить = ',c)
end.

Задача 2.

var
  i: integer;
  x: string;

begin
  readln(x);  i:= 1;
  while x[i]<>'a' do inc(i);  // Здесь, в зависимости с какой буквой сравнивать, либо с русской, либо с англ.
  writeln(i)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота