sanya48481
19.07.2021 21:59

с информатикой,нужно написать программу в Паскале. «В одномерном массиве A из n элементов найти максимальный среди всех элементов и заменить нулевые элементы на 30.»

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
MarijaKitty
18.12.2021 10:10

const n = 20;

var i, max :integer;

   A: array[1..n] of integer;

begin

 max := 0;

 write('Массив A: ');

 for i := 1 to n do

 begin

   A[i] := random(0, 10);

   write(A[i], ' ');

   if A[i] > max then max := A[i];

 end;

 writeln();

 writeln('Максимальный элемент: ', max);

 write('Массив с заменами: ');

 for i := 1 to n do

 begin

   if A[i] = 0 then A[i] := 30;

   write(A[i], ' ');

 end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота