mjsden80
26.05.2023 13:38

1.ввести с клавиатуры массив 8 элементов увеличить каждый элемент на 4 и вывести на экран 2. написать программу.Ввести с клавиатуры массив из 8 элементов.Увеличить все 4 все элементы в первой половине массива и увеличть в 4 раза все элементы во второй половине массива. вывести на экран.3.Написать программу. заполните массив А из 8 элементов на экран. (язык паскаль)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
anastejsablek
31.07.2021 17:20
Var a,b,c,max,two: Integer;
begin
writeln('Введите 1 число');
readln(a);
writeln('Введите 2 число');
readln(b);
writeln('Введите 3 число');
readln(c);
max:=a;
if max < b then max:=b;
if max < c then max:=c;
if max=a then
begin
two:=max;
if c < b then two:=b;
if c > b then two:=c;
writeln(max,'+',two,'=',max+two);
end;
if max=b then
begin
two:=max;
if c < a then two:=a;
if c > a then two:=c;
writeln(max,'+',two,'=',max+two);
end;
if max=c then
begin
two:=max;
if a < b then two:=b;
if a > b then two:=a;
writeln(max,'+',two,'=',max+two);
end;
end.
0,0(0 оценок)
Ответ:
BPAN321
12.12.2020 01:16
Program SummaDrobi;
// это необязательная строчка с названием программы 
var a, b, c, d, n, m: integer; 
// это объявление 6-ти переменных целого типа для хранения данных
begin 
writeln ('Сейчас присвоим 4-м переменным значения и найдём сумму 2 дробей:');
// это вывод на экран текста
a := 2; b := 5; c := 3; d := 7;
// это присвоение значений в переменные из самой 
// программы (ввод данных с клавиатуры отсутствует)
writeln ('Первая дробь равна: ' ,a, '/', b, ', вторая дробь равна: ', c, '/', d);
// это уже вывод обработанной информации на экран
writeln ('Теперь найдём сумму дробей ');
n := a*d; m := c*b; 
// это обработка данных перед выводом на экран
writeln ('Конечная несокращённая дробь равна: ', n+m, '/', b*d);
// это вывод на экран конечного решения
end.

Результат:
Сейчас присвоим 4-м переменным значения и найдём сумму 2 дробей:
Первая дробь равна: 2/5 вторая дробь равна: 3/7
Теперь найдём сумму дробей 
Конечная несокращённая дробь равна: 29/35
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота