annaaverina
05.10.2022 15:01

Написать программу, которая определяет количество учеников в классе, чей рост превышает средний. Массив вводится с клавиатуры. Для завершения ввода нажмите 0. Исходный массив: 178 170 180 168 170 0

Результат: Средний рост=172,6 см
У 2 человек рост превышает средний

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Dinara0103
24.08.2022 11:15

Объяснение:

#include <iostream>

using namespace std;

int main()

{

setlocale(LC_ALL, "RUSSIAN");

const int n = 5;             // (1≤N≤1000)

int mass[n] = { 5, 4, 3, 2, 1 };

int k = 0;

cout << "Исходный массив: ";

for (int i = 0; i < n; ++i)

{

 cout << mass[i] << " ";

}

cout << endl;

for (int i = 1; i < n; i++) {

 for (int j = 0; j < n-1; j++) {

  if (mass[j] > mass[j + 1]) {

   int b = mass[j]; // создали дополнительную переменную

   mass[j] = mass[j + 1]; // меняем местами

   mass[j + 1] = b; // значения элементов

   k++;

  }

 }

}

cout << "Отсортированный массив: ";

for (int i = 0; i < n; ++i)

{

 cout << mass[i] << " ";

}  

cout << endl << "Kоличество обменов: " << k << endl;

system("pause");

return 0;

}

0,0(0 оценок)
Ответ:
3482785525
24.08.2022 11:15

Объяснение:

#include <iostream>

using namespace std;

int main()

{

setlocale(LC_ALL, "RUSSIAN");

const int n = 5;             // (1≤N≤1000)

int mass[n] = { 5, 4, 3, 2, 1 };

int k = 0;

cout << "Исходный массив: ";

for (int i = 0; i < n; ++i)

{

 cout << mass[i] << " ";

}

cout << endl;

for (int i = 1; i < n; i++) {

 for (int j = 0; j < n-1; j++) {

  if (mass[j] > mass[j + 1]) {

   int b = mass[j]; // создали дополнительную переменную

   mass[j] = mass[j + 1]; // меняем местами

   mass[j + 1] = b; // значения элементов

   k++;

  }

 }

}

cout << "Отсортированный массив: ";

for (int i = 0; i < n; ++i)

{

 cout << mass[i] << " ";

}  

cout << endl << "Kоличество обменов: " << k << endl;

system("pause");

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота