staritsckymax
14.03.2023 08:33

Написать программу на Kotlin - найти сумму и произведение всех цифр любого числа

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
bedboy777
02.03.2021 12:47

a=int(input('Введите первое число: ')

b=int(input('Введите второе число: ')

c=int(input('Введите третье число: ')

if a > b and c:

  print('Наибольшее число: ',a)

elif b > a and c:

  print('Наибольшее число: ',b)

else c > b and a:

  print('Наибольшее число: ',c)

Объяснение:

Первые три команды отвечают за добавление переменным значение, которые будут введены пользователем.

if,elif,else ставят условие, при котором будет выполнено следующие условия, так как переменных 3, то мы вводим ее три раза, каждый раз редактируя ее.

Все они сделаны по таком принципу, если True(правда), то выполнить действие, если False(неправда), то действие отменяется.

В данных командах написано, если а больше b и c, то выполнится условие и на экран выведится текст, с наибольшем числом a.

Если условие не выполняется, программа переходит к условию ниже, если оно аналогично не выполняется, оно переходит к третьему.

0,0(0 оценок)
Ответ:
iworld2rist
02.03.2021 12:47

Uses
  Crt;
Var
  i, N, kol: byte;
  sum_rost, sr_rost: real;
  team: array[1..100] of real;
Begin
  sum_rost := 0.0;
  sr_rost := 0.0;
  kol := 0;
  write('Введите количество членов команды');
  read(N);
  writeln('Введите рост каждого члена команды');
  for i := 1 to N do
    begin
      readln(team[i]);
      sum_rost := sum_rost + team[i];
    end;
  sr_rost := sum_rost / N;
  for i := 1 to N do
    if (team[i] > sr_rost) then
      kol := kol + 1;
  writeln('Количество членов команды, рост которых превышает средний по команде (', sr_rost:4:2, ')');
  write(' равно ', kol);
End.

Я надеюсь надо было на паскале написать?)

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота