evstratovamash1
26.04.2021 09:22

Напишите программу и нарисуйте блок-схему На вход подается натуральное число Н, затем Н натуральных чисел. Найти произведение максимального четного числа и минимального нечетного числа из ряда чисел.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
СашаВай1
22.06.2022 16:47

Обилие инструментов интернет-маркетинга вынуждает компании искать новые эффективные реализации интернет-коммуникаций с клиентами. Одним из таких является маркетинг в социальных сетях SMM, под которым подразумевается совокупность мероприятий, направленных на использование социальных медиа, таких как социальные сети, блоги, форумы, фотои видеохостинги и т.д., в качестве каналов продвижения. Это позволяет компаниям выделиться из большого количества конкурентов, привлечь потенциальных потребителей, повысить уровень лояльности клиентов, а также заметно снизить затраты на интернет-рекламу.

Объяснение:

Social Media Marketing- это комплекс мероприятий по использованию разновидных соц. сетей, таких как: Facebook, Instagram, Одноклассники. ru, в качестве каналов для продвижения компаний, их продукции, услуг, которые они предоставляют и решения других бизнес-задач.

0,0(0 оценок)
Ответ:
0p3n
21.05.2021 20:11

#include <iostream>

#include <vector>

#include <cmath>

#include <set>

using namespace std;

void swap(int *a, int *b){

   int temp = *a;

   *a = *b;

   *b = temp;

}

signed main() {

   set<pair<int,int>> s;

   int n;

   cin >> n;

   vector<int> a(n);

   for(int &i:a)

       cin >> i;

   int m;

   cin >> m;

   while(m--){

       int x,y;

       cin >> x >> y;

       s.insert({x,y});

       s.insert({y,x});

   }

   for(int i = 0; i < n; i++)

       for(int j = 0; j < n - i - 1; j++)

           if(a[j] > a[j+1] && s.find({a[j],a[j+1]}) == s.end())

               swap(a[j],a[j+1]);

   for(int &i:a)

       cout << i << " ";

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота