BlackCat20101
09.09.2022 00:54

§ 18. Линейные программы 1. Требуется написать программу, которая складывает два числа и выводит на экран их сумму. Определите входные данные и результат этого алгоритма.

К какому типу относятся входные данные:

Сколько входных значений у алгоритма?

К какому типу относятся результаты:

Сколько результатов у алгоритма?

Обозначьте именами входные данные и результаты и напишите их на стрелках:

Запишите формулу, которая связывает исходные данные и результат:

Место для ввода текста.

2. Требуется написать программу, которая выводит скорость и время движения автомобиля и выводит на экран расстояние, которое он проехал. Определите входные данные и результат этого алгоритма.

К какому типу относятся входные данные:

Сколько входных значений у алгоритма?

К какому типу относятся результаты:

Сколько результатов у алгоритма?

Обозначьте именами входные данные и результаты и напишите их на стрелках:

Запишите формулу, которая связывает исходные данные и результат:

Место для ввода текста.

3. В языке Python целые переменные относятся к типу (классу) int. Выясните, откуда произошло сокращение int в языках программирования:

int – это сокращение от английского слова , которое переводится как .

4. Выделите красным цветом недопустимые имена переменных:

1 Vasya СУ-27 @mail_ru

m11 Петя СУ_27 lenta.ru

1m Митин брат _27 "Pes barbos"

m 1 Quo vadis СУ(27) <Ладья>

5. Что появится на экране после выполнения программы:

c = 5

print( с )

print( 'c' )

ответ:

Чем отличаются два оператора вывода в программе?

Место для ввода текста.

6. Что выведет на экран программма

a = 1

print( a )

a = 5

print( a ) ответ:

Заполните пропуски: «Если переменной присваивается новое значение, то предыдущее значение .»

Выберите правильный вариант: «Переменная в любой момент может иметь ».

7. Чему будут равны значения переменных a и b после выполнения программмы, если вначале они имели значения a = 4 и b = 7? Выполните ручную прокрутку программы.

a b

4 7

a = a + 1

b = b + 1

a = a + b

b = b + a

a = a + 1

ответ: a = b =

8. Что выведет эта программа при a = 4, b = 5 и c = 9?

print( 'a', '+b', =, c )

Место для ввода текста.

9. Исправьте ошибки в операторе вывода,

print( 'c', '-b', =, a )

чтобы при a = 4, b = 5 и c = 9 программа вывела 9–5=4:

Место для ввода текста.

10. Определите порядок действий компьютера при вычислении выражения (впишите номер выполняемого действия над знаком операции):

11. Запишите присваивание на языке программирования:

Место для ввода текста.

12. Как можно записать возведение в квадрат, куб, 10-ю степень на языке Python?

с  x2 d  (x+2)3

d  12+z10

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
KrystallBlack
10.10.2020 19:01
// тестировалось на C#.Net Framework 4.5
using System;

class Program
{
    static void Main()
    {
        int x1 = 2, y1 = 1;
        int x2 = 6, y2 = 5;
        int x3 = 10, y3 = 1;

        var a = Distance(x2, y2, x3, y3);
        var b = Distance(x1, y1, x3, y3);
        var c = Distance(x2, y2, x1, y1);

       
        Console.WriteLine("S = {0}", Square(a, b, c));
        Console.ReadKey();
    }

    //растояние между точками
    static double Distance(int x1, int y1, int x2, int y2)
    {
        return Math.Sqrt((x2 - x1) * (x2 - x1) + (y2 - y1) * (y2 - y1));
    }

    //формула герона
    static double Square(double a, double b, double c)
    {
        var p = (a + b + c) / 2;
        return Math.Sqrt(p * (p - a) * (p - b) * (p - c));
    }

    // теорема косинусов
    static double Angle(double a, double b, double c)
    {
        return Math.Acos((b * b + c * c - a * a) / (2 * b * c));
    }

    static bool IsAcuteAngel(double alpha)
    {
        return alpha < Math.PI / 2;
    }
}
0,0(0 оценок)
Ответ:
ЛаймовыйКотик00
24.05.2022 05:41
//PascalABC.NET (версия 3.1, сборка 1198 от 11.03.2016)
var a,n,k,i,j,s:integer;
begin
  writeln('Количество учеников и количество оценок');
  readln(n,k);
  for i:=1 to n do begin
    for j:=1 to k do begin
      write('Ученик № ',i, ' оценка № ',j,' = ');
      readln(a);
      s:=s+a;
    end;
  end;
  println('Средняя оценка группы ',s/(n*k):6:3);
end.

Тестовое решение:
Количество учеников и количество оценок
3 3
Ученик № 1 оценка № 1 = 3
Ученик № 1 оценка № 2 = 4
Ученик № 1 оценка № 3 = 4
Ученик № 2 оценка № 1 = 5
Ученик № 2 оценка № 2 = 4
Ученик № 2 оценка № 3 = 4
Ученик № 3 оценка № 1 = 4
Ученик № 3 оценка № 2 = 3
Ученик № 3 оценка № 3 = 3
Средняя оценка группы  3.778
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота