макс3102
28.05.2023 16:49

Программа получает на вход последовательность целых чисел, каждое число записано в отдельной строке. Последовательность завершается числом
0, при считывании которого программа должна закончить свою работу и
вывести количество четных положительных членов последовательности (не
считая завершающего числа 0).
Входные данные Выходные данные

1
2 1
-4
0
5

0 0
2
4

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Dasulya21
16.02.2022 07:12

c = 0

while True:

   a = int(input())

   if a == 0:

       break

   if a > 0:

       c += 1

print(c)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота