SanyaLe9
11.02.2020 04:27

Составить программу,вычисляющую значение выражения. На паскале. Пример номер 7 и 8 решить плз , очень надо, заранее .


Составить программу,вычисляющую значение выражения. На паскале. Пример номер 7 и 8 решить плз , очен

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ainurpandaa
25.09.2022 21:25

program z1;

var a: array [1..15] of real;

i, k, b: integer;

proizv: real;

begin

proizv:= 1;

a[1]:= 0.01;

a[2]:= -3;

a[3]:= 0;

a[4]:= 1.25;

a[5]:= -371;

a[6]:= 0.5;

a[7]:= -0.1;

a[8]:= 1.2;

a[9]:= -5;

a[10]:= -172.3;

a[11]:= 19783;

a[12]:= -2.7;

a[13]:= 43.51;

a[14]:= 0;

a[15]:= -0.02;

b:= -3;

k:= 0;

for i:=1 to 15 do

begin

if (a[i] <> 0) and (a[i] > b) then

begin

proizv:= proizv * a[i];

k:= k+1;

end;

end;

writeln('Количество чисел, подходящих условию: ', k);

writeln('Произведение чисел, подходящих условию: ', proizv);

end.

Объяснение:

На фото нарисована блок-схема, она немного криво сфоткана, надеюсь разберёшься. Если есть вопросы - задавай :)


с информатикой надо. Составить блок-схему алгоритма и программу на Паскале для обработки массива из
с информатикой надо. Составить блок-схему алгоритма и программу на Паскале для обработки массива из
0,0(0 оценок)
Ответ:
weelrockster
19.12.2022 20:53

program z1;

var a: array [1..15] of real;

i, k, b: integer;

proizv: real;

begin

proizv:= 1;

a[1]:= 0.01;

a[2]:= -3;

a[3]:= 0;

a[4]:= 1.25;

a[5]:= -371;

a[6]:= 0.5;

a[7]:= -0.1;

a[8]:= 1.2;

a[9]:= -5;

a[10]:= -172.3;

a[11]:= 19783;

a[12]:= -2.7;

a[13]:= 43.51;

a[14]:= 0;

a[15]:= -0.02;

b:= -3;

k:= 0;

for i:=1 to 15 do

begin

if (a[i] <> 0) and (a[i] > b) then

begin

proizv:= proizv * a[i];

k:= k+1;

end;

end;

writeln('Количество чисел, подходящих условию: ', k);

writeln('Произведение чисел, подходящих условию: ', proizv);

end.

Объяснение:

На фото нарисована блок-схема, она немного криво сфоткана, надеюсь разберёшься. Если есть вопросы - задавай :)


с информатикой надо. Составить блок-схему алгоритма и программу на Паскале для обработки массива из
с информатикой надо. Составить блок-схему алгоритма и программу на Паскале для обработки массива из
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота