Войти
Регистрация
Спроси ai-bota
jookyun
17.07.2021 07:43
Дан массив размерностью 7х6 из целых чисел. Напишите программу вычисления среднего арифметического элементов массива среди, двузначных чисел, у которых последняя цифра четная.(Паскаль)
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
oobostoo
09.04.2020 15:35
Обчисліть:10101010^2 - 250^8 + 7^16. Запишіть відповідь у двійковій системі числення....
pahalovrzx
04.08.2021 09:48
Дан код с номером. Определи, какой это символ: управляющий или изображаемый.Код с номером...
loshka2256
04.08.2021 09:48
BigData-ны пайдаланудың оң және теріс әсерлеріне екі мысал ұсыныңдар ...
Виолетик5
26.08.2022 23:37
Костя и Саша решили заранее узнать, какую оценку в четверти по информатикеим выставит учитель. Костя в течение четверти получил три отметки, а Саша - четыре. Пользоваться...
dashadgankozde8z
11.04.2022 17:40
Составить таблицу состоящую из 5 столбцов Студент Оценка по математике оценка по физике оценка по информатике Результат...
Alexy7406
15.04.2022 16:37
Свяжите ячейки С4, С5, С6, С7, С8 в таблице Расходы на закупку на листе Цена с соответствующими ячейками на листе Закупка, используя различные связывания ячеек. При связывании...
Школьник7555
19.11.2022 13:02
Как это можно записать в с++?...
rouberuplay
02.02.2021 21:21
Напишите ахк скрипт на повторения нажатий E англ. ...
Дарига65
11.04.2022 09:34
Python. Решите задачу с пояснением...
ztv1978
16.02.2020 09:03
1)региональная метеостанция фиксирует годовые атмосферные осадки в 128 населенных пунктах. за 5 лет наблюдений колебания осадков были в интервале от 100 до 900 мм. специальное...
Ответ:
maezsa
08.11.2021 22:56
1)
var
s: string[6];
n: integer;
begin
s := 'отлично';
n := length(s);
writeln(length('отлично'));
writeln(n);
end.
Изначально выставлен тип string[6], значит если присвоить строку больше, то ее обрежет по 6 символов, вот и весь прикол
ответ 6
2) рисунок
3)var
s, s1: string;
n: integer;
begin
s := 'информатика';
s1 := copy(s, 3, 5);
n := pos(s, s1);
writeln('s=', s);
writeln('s1=', s1);
writeln('n=', n);
end.
Вывод
s=информатика
s1=форма
n=0
Все верно, в s1 не содержится s, а наоборот
0,0
(0 оценок)
Ответ:
MarKizaCat666
09.02.2021 03:01
Var
i, n, s: integer;
begin
readln(n);
i := 0;
s := 0;
while i < 7 do
begin
if (n mod 2 = 1) then begin
s := s + n;
i := i + 1;
end;
n := n + 1;
end;
writeln(s);
end.
var
i, n, s: integer;
begin
readln(n);
i := 0;
s := 0;
repeat
if (n mod 2 = 1) then begin
s := s + n;
i := i + 1;
end;
n := n + 1;
until i >= 7;
writeln(s);
end.
var
i, n, s: integer;
begin
readln(n);
n := n + (n + 1) mod 2;
s := 0;
for i := 1 to 7 do
begin
s := s + n;
writeln(n);
n := n + 2;
end;
writeln(s);
end.
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота