Rororor11111
25.02.2021 08:21

1) Дан массив размерностью 8x6 из целых чисел. Напишите программу поиска минимального элемента массива среди двузначных чисел. 2) Дан массив размерностью 7x7 из целых чисел. Напишите программу замены всех чётных элементов массива, стоящих на побочной диагонале на значение первого массива

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
EvgeshaKhomenco2005
26.07.2021 03:23

program zz1;

var a:integer; // задаем переменную целого типа

n, b, c:real;// задаем переменные не целого типа

begin

write(' введите заданную величину а '); // вводим с клавиатуры число

read(a);

n:= a / 1024; // переводим объем информации в килобайты

b:= (a / 1024) / 1024; // переводим объем информации в мегабайты

c:= ((a / 1024) / 1024) / 1024; // переводим объем информации в гигабайты

writeln(' объем информации в килобайтах = ', n); // выводим ответ

writeln(' объем информации в мегабайтах = ', b);

write(' объем информации в гигабайтах = ', c);

end.

0,0(0 оценок)
Ответ:
nik180208
22.07.2021 19:20

1)а

var a:real;

begin

readln(a);

a1 := a*a;  /получили а^2
a := a1*a1;  /получили a^4

a := a1*a*a;  /получили a^(4+4+2)

writeln(a);

end.

 

1б)

var x:real;

i:integer;

begin

readln(a);

a1 := a*a*a;  /получили а^3
a := a1*a1*a1;  /получили a^9

a := a*a1*a1; /получили а^(9+3+3)

writeln(a);

end.

 

2)

var a:real;
begin
readln(a);
writeln('высоты равны', a*a*sqrt(3)/4*a);
writeln('Радиус вписанной окружности', a*a*a/4*a*a*sqrt(3)/4);
writeln('Радиус описанной окружности', a*a*sqrt(3)/4*2/3*a);
end.

 

3)var a:real;
begin
readln(a);

writeln('В килобайтах' a/1024);

writeln('В мегабайтах' a/(1024*1024));

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота