wwe555
05.05.2021 10:40

Напишите программу на любом известном вам алгоритмическом языке. на вход программе подается число n. далее вводится n чисел. программа определяет, будет ли произведение этих чисел положительным

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
lenaseredenko
26.06.2020 14:56
Произведение чисел положительно, если среди них есть четное количество отрицательных чисел. И отрицательно, если их нечетное количество.
Я просто алгоритм напишу
1) Вводим число N
2) Устанавливаем счетчик k = 0
3) Цикл по i от 1 до N
3.1) Вводим очередное число
3.2) Если число < 0, то прибавляем счетчик k = k + 1
3.3) Конец цикла
4) Если число k четное (k mod 2 = 0), то результат положительный
Если k нечетное (k mod 2 = 1), то результат отрицательный.
5) Конец
А вот делать так, как Sky предлагает, я бы не стал. Он тупо перемножает числа.
Произведение может оказаться слишком большим, да оно нам и не нужно.
0,0(0 оценок)
Ответ:
усенок
26.06.2020 14:56
Паскаль

uses crt;
var n,pr,x:integer;
    a: array [1..1000] of integer;
begin
     write('Введи количество чисел последовательности:');
     readln(n);
     pr:=1;
     for x:=1 to N do
     begin
          readln(a[x]);
          pr:=pr*a[x];
     end;
     if pr>0 then writeln('YES')
        else writeln('NO');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота