allihen
13.04.2022 09:48

Паскаль.Вася пришел в магазин купить U карандашей и R ручек. Карандаши стоят L рублей, а ручки J рублей ему сосчитать, сколько рублей ему нужно на покупку. Напишите программу. Общую стоимость покупки обозначьте за S.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ElizabetSnow
27.06.2020 05:28
2) Все записи в базе данных имеют:
Если здесь вопрос понимать "Все записи в таблице реляционной БД имеют", то ответ, скорее всего, 
d) Одинаковое количество полей

3) Укажите правильную последовательность действий при работе с базами данных (составить последовательность из букв):
c) Продумать структуру базы данных 
d) Дать имя каждому полю в базе данных
a) Занести данные в таблицу
b) Осуществить сортировку записей в базе данных

4) Поиск информации– это:
a) выбор информации по определённым правилам

5) Примером базы данных может служить:
Скорее всего
b) Телефонный справочник,
хотя и 
c) Энциклопедия тоже может быть

6) В каком из перечисленных типов полей, данные могут выглядеть таким образом: 
Да или Нет ?
b) В логическом поле

7) В какой из перечисленных пар данные относятся к одному типу?
a) 12.04.98 и 01/02/99;  - тип дата
b) ДА и TRUE (ИСТИНА);  - логический тип

8) База Данных содержит информацию о каждой собаке из клуба собаководства: кличка, порода, дата рождения, пол, количестве медалей. Какого типа должны быть поля?
d) текстовое, текстовое, дата, текстовое, числовое;

Возможно, такие ответы. Хотя многие вопросы некорректны.
0,0(0 оценок)
Ответ:
Умныйгоблин
15.01.2022 21:48
Const
 n = 20;

var
 pos,neg: integer;
 i,k,x: integer;
 ev,un: integer;
 a,b: array [1..n] of integer;

begin
 for i := 1 to n do
   read(a[i]);
  k := 0;
 pos := 0;
 neg := 0;
  for i := 1 to n do
   begin
      ev := 0;
   un := 0;
      x := a[i];
      if x <> 0 then
     if x > 0 then
       if (x < pos) or (pos = 0) then
         pos := x
       else
     else
       if (x > neg) or (neg = 0) then
         neg := x;
      x := abs(x);
      while x <> 0 do
     begin
     if odd(x) then
       un := un + 1
     else
       ev := ev + 1;
     x := x div 10
     end;
      if un = ev then
     begin
     k := k + 1;
     b[k] := a[i]
     end
      end;

 writeln(pos,' ',neg);
 for i := 1 to k do
   write(b[i],' ')
 end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота