Anansiy
28.05.2020 03:46

3. Напишите программу в тетради, которая создает новый файл и записывает в нем ваше имя/3

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Anna14124
25.01.2021 21:10


1. в случаях, когда надо выполнить не следующий по порядку оператор, а какой-нибудь другой, отмеченный меткой (например выйти из цикла)
4. "следование", "ветвление", "цикл с предусловием"
5.  для осуществления на него безусловного перехода;
6. для вывода графики
7. для очистки экрана
8. операторы присваивания, безусловный оператор, оператор вызова процедуры, пустой оператор
9. power(x,y)
10. integer
11. :=
12. F9
13. write и writeln
14. Раздел описаний
16.  операторы, не содержащие никаких других операторов    
17. операторы присваивания, безусловный оператор, оператор вызова процедуры, пустой оператор
18. for; while.. do; repeat...until
19. текстовые файлы; типизированные файлы; нетипизированные файлы
опрераторов if и case of
29.  writeln без параметров
30.  :
31.  закрашивает замкнутую область, используя текущие стиль и цвет закраски.
32.  вывод на экран прямоугольников
33.  Объяснения програмиста.
34.  Никаких действий не выполняет, нужен для осуществления на него безусловного перехода
35.  покомандный анализ, обработку и выполнение исходной программы
36.  Никлаус Вирт в 1968—1969
37.  весь блок, в котором объявлена данная метка, за исключением внутренних блоков
38.  Отметьте, из каких элементов состоит алгоритмический язык?
39.  Program
40.  Var
41.  Set of
42. Шесть: следование; ветвление; цикл с предусловием; цикл с постусловием; цикл с параметром; вариант.
43.  Укажите приоритет операций в языке Паскаль.
44.  26 латинских строчных и прописных букв; знак подчеркивание; 10 цифр; знаки операций; ограничители; спецификаторы; служебные слова; пробел.
45.  26 латинских строчных и прописных букв; знак подчеркивание; 10 цифр; знаки операций; ограничители; спецификаторы; служебные слова; пробел.
47.   предложение языка программирования, задающее полное описание некоторого действия, которое может выполнить компьютер
48.   данные, необходимые для выполнения оператора
49.  begin ... end
50.  S - начиная с позиции курсора, выводится значение S (строка или массив символов)
51.  имя метки и двоеточие после него
52.  компилятор - это программа-переводчик, читает всю программу целиком, делает ее перевод и создает законченный вариант программы на машинном языке, который затем и выполняется

0,0(0 оценок)
Ответ:
Kashakom04
04.08.2020 01:15

числа в if берутся из кодов ASCII

Объяснение:

#include <stdio.h>

#include <string.h>

int

main ()

{

 char s[10001];

 int i = 0;

 for (int j = 0; j < 10001; j++) {

     scanf("%c", &s[j]);

     if (s[j] == '\n')

         break;

 }

 while (s[i] != '\n')

   {

   if (((int)s[i] > 64 && (int)s[i] < 91) || ((int)s[i] > 96 && (int)s[i] < 123))

     if ((int)s[i] > 124)

s[i] = (char)((int)s[i] - 92); //3-127+32=92

else

       s[i] = (char)((int)s[i] + 3);

   i++;

   }

 for (int j = 0; j < i; j++)

     printf("%c", s[j]);

 return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота