Radjabaliev
30.06.2021 10:18

В классе писали контрольную работу по математике. Напишите программу, которая вычисляет количество "2" "3" "4" "5" в классе. Исходные данные: количество учеников. в классе, оценки вводятся случайным образом. В !

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
irasemenova1
21.10.2020 14:31
Type tbank=record
name:string;
curs:real;
end;
var banks:array[1..15] of tbank;
max,dollars:real;
i,mi:longint;
Begin
Write('You have: ');
readln(dollars);
for i:=1 to 15 do Begin
Write('Bank name: ');
readln(banks[i].name);
write('Curs: ');
readln(banks[i].curs);
end;
max:=dollars*banks[1].curs;
mi:=1;
for i:=2 to 15 do
Begin
if(dollars*banks[i].curs>max) then Begin
max:=dollars*banks[i].curs;
mi:=i;
end;
end;
writeln('Best bank name: ',banks[mi].name,', curs is :',banks[mi].curs:2:2,', we will get: ',max:2:2,', rub.');
end.
0,0(0 оценок)
Ответ:
Davidovaliza
31.08.2021 07:41
Программа на языке Паскаль.

const N=30;
var i, s0, k, a: integer;
      b: array [1..N] of integer;
begin
      readln(a);
      s0:=0;
      k:=0;
      randomize;
      for i:=1 to N do
      begin b[i]:=random(20001)-10001; {чтобы диапазон случайных чисел был от -10000 до 10000}
                if (b[i]<0) then s0:=s0+b[i];
                if (b[i]>0) and (b[i]<=a) then inc(k);
      end;
      if (s0<>0) then writeln(s0, ' - сумма отрицательных чисел')
      else writeln('отрицательных чисел нет');
      if (k<>0) then writeln(k, ' - количество положительных чисел, не превосходящих числа А')
      else writeln('положительных чисел не превосходящих числа А, нет');
readln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота