Forkier
20.09.2022 21:06

задачка по информатике. Операторы циклов Написать программу для вычисления заданного выражения и вывода на экран полученного значения, используя заданный циклический оператор.
Выражение: 0,8 - 0,10 + 0,12 -...- 0,26
оператор цикла: while

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
кувшинкаВейВей
13.02.2022 11:50

numb = 8

step = 2

pred = 26

da = float('0.'+str(numb))

opr = False

while numb < pred:

   numb += step

   if opr:

       da += float('0.'+str(numb))

   else:

       da -= float('0.'+str(numb))

   opr = not opr

print(round(da,5))

Если есть вопросы - пиши

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота