1231231221312223
02.11.2021 07:21

30 ! составьте программу ,которая формирует массив ,содержащий 12 случайных вещественных чисел ,принадлежащих промежутку от [-10; 30] , и подсчитывает произведение всех отрицательных чисел. вывод в столбец с тремя десятичными знаками.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ololsha99
27.06.2020 01:52
var
a:array[1..12] of real;
i:integer;
pr:real;
begin
randomize;

pr:=1;for i:=1 to 12 do begin
  a[i]:=random(41)*0.9-10;
  if (a[i] < 0) then
    pr:=pr*a[i]; 
end;
writeln(pr:5:3)
end.
0,0(0 оценок)
Ответ:
Foxer30
27.06.2020 01:52
Uses crt;
var a:array[1..12] of real;
    x:integer;
    p:real;
begin
     randomize;
     p:=1;
     for x:=1 to 12 do
     begin
          a[x]:=random(41)*(random(10)/5)-10;
          writeln('a[',x,']:',a[x]);
          if a[x]<0 then p:=p*a[x];
     end;
     writeln;
     writeln(p:6:3);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота