akm0910
01.11.2021 04:08

если при составлении программы нужно ввести два числа, то это будет выглядить следующим образом a=input(a,b) a,b=input(a), input(b) input(a,b)

выберите правильную запись оператора при выводе суммы двух чисел print() print(a+b) print('a+b)

соотнесите арифметические действия и их запись при составлении программы /

** abs() умножение деление степень числа модуль умножение деление степень числа модуль

Выберите правильную запись формулы при составлении программы на нахождения суммы двух чисел s=a+b =a+b a+b

Составьте программу на нахождение значения выражения у= 2x+7.5, если х нужно ввести с клавиатуры *

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
умник1308
01.06.2020 11:19
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
type
  Matrix=array[,] of integer;

procedure MatPrint(a:Matrix);
begin
  var m:=Length(a,1)-1;
  for var i:=0 to Length(a,0)-1 do begin
    for var j:=0 to m do Write(a[i,j]:4);
    Writeln
    end
end;

function IsEqual(a:Matrix; col:integer):boolean;
begin
  var s:=sign(a[0,col]);
  for var i:=1 to Length(a,0)-1 do s+=sign(a[i,col]);
  if (s=0) then Result:=(a[0,col]<>0)
  else Result:=false
end;

procedure DeleteCol(var a:Matrix; col:integer);
begin
  var n:=Length(a,0)-1;
  var m:=Length(a,1)-1;
  for var j:=col+1 to Length(a,1)-1 do
    for var i:=0 to n do a[i,j-1]:=a[i,j];
  SetLength(a,n+1,m)
end;

begin
  var n:=ReadInteger('Строк:');
  var m:=ReadInteger('Столбцов:');
  var a:=MatrixRandom(n,m,-99,99);
  Writeln('Исходная матрица');
  MatPrint(a);
  for var j:=Length(a,1)-1 downto 0 do
    if IsEqual(a,j) then DeleteCol(a,j);
  Writeln('Результирующая матрица');
  MatPrint(a);  
end.

Тестовое решение
Строк: 8
Столбцов: 10
Исходная матрица
  -3 -82 -25 -22  65   1  79 -67 -64 -82
  17  36  48 -32  51  11  43   9 -35   4
 -10  -5  80  82 -24  66 -12 -58  50 -94
  52  70  53  85 -32 -59  46  57 -84 -44
  81  71 -55  37  46 -15 -61  25  22  -7
 -49  98 -42 -18 -44 -97 -63  -7 -98  99
 -86  37 -17 -69 -35  46  82  62  99  11
  65  85  -7 -90  23  19 -50 -56 -64  91
Результирующая матрица
 -82 -25 -22   1 -64
  36  48 -32  11 -35
  -5  80  82  66  50
  70  53  85 -59 -84
  71 -55  37 -15  22
  98 -42 -18 -97 -98
  37 -17 -69  46  99
  85  -7 -90  19 -64
0,0(0 оценок)
Ответ:
bastovayasofia
26.12.2020 23:26

е задание: «Кодирование графической и звуковой

информации, объем и передача информации»

Уровень сложности — базовый,

Требуется использование специализированного

программного обеспечения — нет,

Максимальный — 1,

Примерное время выполнения — 5 минут.

Проверяемые элементы содержания: Умение определять

объём памяти, необходимый для хранения графической и

звуковой информации

Задание 7_1:

ЕГЭ по информатике 2017 задание 7 (9) ФИПИ вариант 1 (Крылов С.С.,

Чуркина Т.Е.):

Какой минимальный объем памяти (в Кбайт) нужно зарезервировать,

чтобы можно было сохранить любое растровое изображение

размером 160 х 160 пикселей при условии, что в изображении могут

использоваться 256 различных цветов? В ответе запишите только целое

число, единицу измерения писать не нужно.

ответ: 25

Показать решение:

 Используем формулу нахождения объема:

I = M x N * i

 Подсчитаем каждый сомножитель в формуле, стараясь привести числа к

степеням двойки:

o M x N:

160 * 160 = 20 * 2³ * 20 * 2³ = 400 * 26 =

= 25 * 24 * 26

o Нахождение глубины кодирования i:

256 = 28

т.е. 8 бит на пиксель (из формулы кол-во цветов = 2i)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота