vladimer96
04.02.2022 09:36

Написать программу на C, где водится трёхзначное число a и нужно поменять крайние числа местами. Входные данные: 649
Выходные: 946


Написать программу на C, где водится трёхзначное число a и нужно поменять крайние числа местами. Вхо

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vitusyaischuk
09.07.2020 08:26
Код Pascal;

Var
   x,y,v,h,dx:real;
Begin
Write('y = ');ReadLn(y);
Write('v = ');ReadLn(v);
Write('h = ');ReadLn(h);
dx:=0.31;
x:=-4;
Repeat
WriteLn('f(',x,') = ',Exp(Sin(y)*Abs(x))-3*Sqrt(v-h));
x:=x+dx;
Until x > -1
End.

Пример работы программы:

y = 3
v = 4
h = 2
f(-4) = -2.4841075227142
f(-3.69) = -2.55937994576573
f(-3.38) = -2.63143040076643
f(-3.07) = -2.70039680114727
f(-2.76) = -2.76641115707942
f(-2.45) = -2.82959982815798
f(-2.14) = -2.89008376526975
f(-1.83) = -2.94797874210812
f(-1.52) = -3.00339557677815
f(-1.21) = -3.05644034391605
0,0(0 оценок)
Ответ:
svetamax70
09.07.2020 08:26

Код ко второй и восьмой задачам:

{2-nd task}

var t,p,x,a,y: real;

begin

   write('t = ');

   readln(t);

   write('p = ');

   readln(p);

   write('x = ');

   readln(x);

   write('a = ');

   readln(a);

   y:= (exp(ln(t)*p))*(exp(ln(x)*5))*(1 - (x - (exp(ln(a)*x)))/((exp(ln(x)*2)) + 5.3));

   writeln('y = ',y:0:2);

end.

{8-th task}

var x,a,y,b,r,q,d: real;

begin

   write('a = ');

   readln(a);

   write('y = ');

   readln(y);

   write('b = ');

   readln(b);

   write('r = ');

   readln(r);

   write('q = ');

   readln(q);

   write('d = ');

   readln(d);

   x:= ((exp(ln(cos(y))*a)) - (exp(ln((sin(exp(ln(r)*8*q*b)))/((exp(ln(d)*(2*a*b))) + 18.31);

   writeln('x = ',x:0:2);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота