YourTeaa
10.06.2021 21:19

ПАСКАЛЬ Написать программу, определяющую, какое расстояние проедет автомобиль за X секунд при скорости 100 км/ч (X вводится с клавиатуры)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
345153
25.06.2022 06:41
Для радиуса описанной окружности имеется соотношение
\displaystyle R= \frac{a}{2\sin A}=\frac{b}{2\sin B}=\frac{c}{2\sin C}; \\ \\ a=2R\sin A \\ b=2R\sin B \\ c=2R\sin C

// PascalABC.NET 3.2, сборка 1367 от 20.12.2016
// Внимание! Если программа не работает, обновите версию!

var
  a,b,c,R,dA,dB,dC:real;
begin
  Writeln('Введите углы A,B в градусах и радиус R');
  Read(dA,dB,R);
  dC:=180-dA-dB;
  a:=2*R*sin(dA*Pi/180);
  b:=2*R*sin(dB*Pi/180);
  c:=2*R*sin(dC*Pi/180);
  Writeln('Угол C: ',dC:0:2);
  Writeln('a=',a:0:5);
  Writeln('b=',b:0:5);
  Writeln('c=',c:0:5)
end.

Пример
Введите углы A,B в градусах и радиус R
30 70 50.0
Угол C: 80.00
a=50.00000
b=93.96926
c=98.48078
0,0(0 оценок)
Ответ:
benblast
25.06.2022 06:41
После смерти александра i, междуцарствия и жестокой расправы над восставшими декабристами на российский престол вступил брат александра николай i. личность николая i неоднозначно оценивалась как современниками, так и последующими . самые убийственные характеристики исходили от представителей современного ему революционного направления, с которым он на протяжении всей своей жизни вел непримиримую борьбу. они писали о нем как о крайне ограниченном монархе, жестоком деспоте и тиране. приближенные, наоборот, восхищались его личными качествами - необыкновенной работоспособностью, порядочностью, скромностью в быту. николая специально не готовили к такой огромной империей, как россия. в молодости он не получил достаточного серьезного образования. его интересовало, прежде всего, военное дело. однако нужно отметить, что его природный ум, железная воля, любовь к дисциплине давали ему возможность достаточно эффективно государством. правление николая i справедливо считается одним из самых реакционных периодов нашей . он прославился бескомпромиссной борьбой с революционными, демократическими движениями не только в россии, но и в европе. осуществляя свой внутриполитический курс, николай i вынужден был учитывать, что в россии продолжало зреть недовольство крестьян своим положением, выражаясь в ряде их выступлений и бунтов. большое влияние на мировоззрение и деятельность николая оказывала общественно-политическая обстановка в европе, бурлившей буржуазными революциями. во второй четверти xix века россия была крупным и сильным в военном отношении государством, способным эффективно решать свои внешнеполитические вопросы. в начале правления николая i военно-техническое отставание россии от европы еще не было так заметно, как впоследствии. армия была многочисленной и считалась одной из самых лучших в мире. основные направления внешней политики сохранились с конца xviii века, когда россия стала складываться как огромная евроазиатская империя. новый российский император поспешил заявить о продолжении внешнеполитического курса своего предшественника. но впоследствии он дал понять, что при проведении политики в европе, россия будет больше полагаться на собственные силы, чем на «федеративную солидарность». николай i сохранил отношения с германскими государствами, в первую очередь с пруссией, которая издавна занимала ведущее место в -германских торговых связей. тогда же наметилась тенденция к сближению россии с и францией. в период царствования николая i центральное место во внешней политике занял восточный вопрос - взаимоотношения с османской империей. 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота