dank02
07.03.2021 16:56

1.Заполните массив случайными числами в интервале (0,20). Введите число X и найдете все значения, равных X. 2. Напишите программу, которая в зависимости от номера месяца выводит времена года. 3. Дан список, а=[1,2,3,4,5,8,11,13,14,16,17]. А) Удалите элемент 8; Б) добавьте в список элемент 22.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Любовь1203
09.03.2022 16:40

Python

1.

import random

X = int(input())

N_spisok = []

N = 20

for i in range(0, N):

   N_random = random.randint(0, N)

   N_spisok.append(N_random)

print(N_spisok)

for i in N_spisok:

   if i == X:

       print(i)

   else:

       break

2.

time = int(input())

zima = [12, 1, 2]

vesna = [3, 4, 5]

leto = [6, 7, 8]

osen = [9, 10, 11]

if time in zima:

   print('Зима')

elif time in vesna:

   print('Весна')

elif time in leto:

   print('Лето')

else:

   print('Осень')

3.

a = [1, 2, 3, 4, 5, 8, 11, 13, 14, 16, 17]

a.remove(8)

a.append(22)

print(a)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота