Чебурашка1234567890
30.09.2020 03:53

Напишите программный код для задачи: Сауле хочет купить n тетрадей и m ручки. Цена одной тетради в магазине – 65 тенге, а ручки – 42 тенге. Напишите программу, которая найдет сумму покупки Сауле в магазине. ВНИМАНИЕ: - за ввод и вывод переменных в программе - за программный код

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Настя789032131
30.08.2021 11:17
// PascalABC.NET 3.0, сборка 1076
var
  a,b,c,p,s:real;
begin
  Writeln('Введите через пробел стороны треугольника: ');
  Read(a,b,c);
  if (a+b>c) and (a+c>b) and (b+c>a) then begin
    p:=(a+b+c)/2;
    s:=sqrt(p*(p-a)*(p-b)*(p-c));
    Writeln('Площадь треугольника равна ',s)
    end
  else Writeln('Невозможно построить треугольник')
end.
 
Тестовые решения:
Введите через пробел стороны треугольника:
10 15 13.6
Площадь треугольника равна 66.3272183948641

Введите через пробел стороны треугольника:
5 8 20.4
Невозможно построить треугольник
0,0(0 оценок)
Ответ:
dzeratigieva
10.11.2021 18:15
Дешифровка: ВХОД_ОТКР Ы Т.

дешифровки:
Const sh = '_.,';
Var
  St : String;
  i  : Integer;
Function DeCode(S : String; Tabl : String; k : Integer) : String;
Var j,n : Integer;
Begin
  For j:=1 to Length(S) do
  Begin
    n:=Pos(S[j],sh);
    If n>0 then
    Begin
      n:=n+k;
      While n>Length(sh) do n:=n-Length(sh);
      While n<=0 do n:=n+Length(sh);
      S[j]:=sh[n];
    end
  end;
  DeCode:=S;
end;
Begin
  St:='ЗЫФЙГФШРЦ . ШД';
  Writeln(Decode(St,sh,-6));
  //For i:=-10 to 10 do Writeln(Decode(St,sh,i));
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота