Raf4ik15
15.10.2021 16:10

Команда разработчиков 2D-игр ищет новых программистов! Сейчас они готовы взять в команду 5 человек, но у них есть несколько правил: кандидату должно быть от 12 и 17 лет, и он обязательно должен любить программировать!

Напишите программу, которая ребятам рассмотреть такое большое количество кандидатов и отобрать из них 5 подходящих.

Как только команда наберет 5 работников, программа должна остановить работу.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
DimazCheat
11.01.2021 05:51
// pascalabc.net 3.3, сборка 1579 от 18.11.2017 // внимание! если программа не работает, обновите версию! begin   writeln('*** исходный массив ***');   var a: =matrrandom(2,4,-10,30);   a.println(4); writeln(4*a.colcount*'-');   writeln('п = ',a.elementsbyrow.where(t-> t.between(1,19))           .aggregate(1,(x,y)-> x*y)) end. пример *** исходный массив ***   24  16  22  12     2    5    1    8 п = 15360
0,0(0 оценок)
Ответ:
vikt24oria
07.06.2021 23:04
Берем третьи байты и переводим в двоичную систему счисления:добавим в начале нулей, чтобы получилось 8 цифр.   ←    ←  найдем маску. запишем с столбик. если элементы одинаковые, ставим соответствующее число, если элементы разные, ставим крестик: 00000101 00011101 000xx101    ← маска т.к. по правилу в маске, сначала идут единицы, переместим их в начало: 11xx0000 если бы по условию, надо было бы найти наименьшее возможное значение, то мы бы заменяли крестики(х) на нули. т.к. по условию необходимо наибольшее возможное значение, подставляем вместо крестиков(x), единицу и переведем в десятичную систему счисления:
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота