nebylobyagjjhgf
15.10.2020 18:18

Задано вещественное значения аргумента X. Составить блок-схему и программу вычисления значение функции Y

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Irinaytsn
21.03.2023 01:59
1) Шина (магистраль) – совокупность проводников (физических линий) данных, адреса и линий передачи сигналов управления, синхронизации и электропитания, а также протоколов обмена данными между устройствами, подключенными к шине.Состав шины – количество линий данных определяет разрядность данных, количество линий адреса определяет адресуемое пространство памяти, количество линий сигналов управления и оповещения, частота шины, определяющая ее пропускную Контроллер шины является устройством, связывающим центральный процессор с периферийными устройствами по сигналу запроса и сигналу готовности внешнего устройства к обмену данными с центральным процессором. При этом управление шиной передается этому внешнему устройству через дешифратор номера и это устройство становится задатчиком шины.Задатчиками (хозяевами) шины могут выступать центральный процессор (обычная ситуация), контроллер ПДП, контроллер регенерации и некоторые платы системы расширения.В каждом цикле обмена задатчиком всегда является только одно устройство. Контроллер ПДП захватывает магистраль (запрещает работу центрального процессора с шиной данных) на время прямой передачи информации между устройством ввода/вывода и памятью (по запросу устройства ввода/вывода).Контроллер регенерации периодически становится задатчиком магистрали для проведения циклов регенерации системной динамической памяти через заданные интервалы времени.Для 32-разрядных компьютеров (386DX, 486, Pentium и т.д.) обмен процессора с памятью (а иногда и с другими устройствами) осуществляется через быстродействующую локальную шину VLB или через РСI.

3)На данный момент активно ведутся разработки молекулярных, оптических и квантовых устройств, а также ДНК-компьютеров. Сложность разработки таких систем заключается в необходимости перестроения всех основных узлов: центрального процессора, элементов памяти, устройств ввода/вывода.В основе молекулярных компьютеров лежат бистабильные молекулы, которые могут находится в двух устойчивых термодинамических состояниях. Каждое такое состояние характеризуется своими химическими и физическими свойствами. Переводить молекулы из одного состояния в другое можно с света, тепла, химических агентов, электрических и магнитных полей. По сути, эти молекулы являются транзисторами размером в несколько нанометров.
0,0(0 оценок)
Ответ:
konfetka7510
18.02.2022 11:34

Комментарий:

Да условие не до конца дописано, но с таким началом условия скорее всего это задача:

определите значение переменной s после выполнения следующего фрагмента программы: s:= 0; for i:=1 to 9 do  if A[i - 1] < A[i] then begin  s := s + 1; t := A[i];  A[i] := A[i - 1];  A[i - 1] := t  end;

Незачем считать, хотя и можно, проще просто запустить этот код:

var a: array [0..9] of integer = (1, 2, 4, 3, 5, 6, 8, 7, 3, 4); i, t, s: integer; begin s := 0; for i:=1 to 9 do if A[i - 1] < A[i] then begin s := s + 1; t := A[i]; A[i] := A[i - 1]; A[i - 1] := t end; write(s); end.

Как мы видим, после выполнения данного в условии фрагмента переменная s будет равна 9.


В программе используется одномерный целочисленный массив а с индексами от 0 до 9. значения элементов
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота