abakanovalera
06.12.2020 15:12

Задачи на циклы. 6. Составьте программу, вычисляющую A*B, не пользуясь операцией умножения. А и B любое натуральное число. 7. Каждая бактерия делится на две в течение одной минуты. В начальный момент имеется одна бактерия. Составьте программу, которая рассчитывает количество бактерий на заданное вами целое значение момента времени (15 минут, 7 минут и т.п.).

8. В 1202г. Итальянский математик Леонард Пизанский (Фибоначчи) предложил такую задачу: пара кроликов каждый месяц дает приплод – двух кроликов (самца и самку), от которых через два месяца уже получается новый приплод, Сколько кроликов будет через год, если в начале года имелась одна пара? Согласно условию задачи числа, соответствующие количеству кроликов, которые появляются через каждый месяц, составляют последовательность 1, 1, 2, 3, 5, 8, 13, 21, 37, … Составьте программу, позволяющую найти все числа Фибоначчи, меньшие заданного числа N.

9. Найти все трехзначные числа, сумма цифр которых равна данному целому числу.

10. Найти все трехзначные числа, средняя цифра которых равна сумме первой и второй цифр.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Fissadi
30.01.2021 11:26
Ctrl+Tab-переключение между закладками или окнами одного приложения
Ctrl+Shift-переключить язык
Ctrl+Alt+Delete-открытие окна "Диспетчер задач" или "Безопасность Windows"
Ctrl+Shift+Esc-открытие окна "Диспетчер задач"
Ctrl+Esc-открытие/закрытие меню "Пуск"
Ctrl+C-копировать в буфер обмена
Ctrl+Insert-копировать в буфер обмена
Ctrl+V-вставить из буфера обмена
Ctrl+X-вырезать в буфер обмена
Ctrl+Z-отменить (назад)
Ctrl+Y-отменить (вперёд)
Ctrl+A-выделить всё
Ctrl+S-сохранить
Ctrl+W-закрыть текущую вкладку окна
Ctrl+R-обновить
Ctrl+Backspace-удалить слово (удаляет влево)
Ctrl+Delete-удалить слово (удаляет вправо)
Ctrl+Home (End)-переместить курсор в начало (конец) текста
Ctrl+Shift+Пробел-в Word: Неразрывный пробел
Ctrl+Shift+Дефис-в Word: Неразрывный дефис
Ctrl+Enter-в Word: Разрыв страницы
Ctrl+P-печать документа
0,0(0 оценок)
Ответ:
olgavish761
25.02.2020 01:48
// PascalABC.NET 3.2, сборка 1387 от 20.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandomReal(ReadInteger('n='),1,50);
  a.Println;
  Writeln('Сумма нечетных элементов : ',
      a.Where((x,i)->i.IsEven).Sum);
  Writeln('Произведение нечетных элементов: ',
      a.Where((x,i)->i.IsEven).Aggregate(1.0,(p,q)->p*q))
end.

Пример
n= 8
15.4810654863161 23.0172746381803 33.7221310123439 43.045114823638 9.12741185358139 5.36693139344777 24.408098445464 16.3833775466231
Сумма нечетных элементов : 82.7387067977054
Произведение нечетных элементов: 116304.750204143
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота