ehot2004
17.07.2021 20:04

. Нужно написать программу в С. Дана прямоугольная таблиця, состоящая из nxm элементов. Поменять местами первый столбец и столбец содержащий максимальный элемент таблицы

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ironthewolf72
30.05.2023 14:39

Звичайно! Ось приклад програми на мові C, яка здійснює обмін місцями першого стовпця і стовпця з максимальним елементом в прямокутній таблиці:

Объяснение:

#include <stdio.h>

#define MAX_SIZE 100

int main() {

   int table[MAX_SIZE][MAX_SIZE];

   int n, m;

   // Введення розмірів таблиці

   printf("Введіть кількість рядків (n): ");

   scanf("%d", &n);

   printf("Введіть кількість стовпців (m): ");

   scanf("%d", &m);

   // Введення елементів таблиці

   printf("Введіть елементи таблиці:\n");

   for (int i = 0; i < n; i++) {

       for (int j = 0; j < m; j++) {

           scanf("%d", &table[i][j]);

       }

   }

   // Знаходження максимального елемента та його стовпця

   int maxElement = table[0][0];

   int maxColumn = 0;

   for (int j = 0; j < m; j++) {

       if (table[0][j] > maxElement) {

           maxElement = table[0][j];

           maxColumn = j;

       }

   }

   // Обмін стовпця з максимальним елементом і першого стовпця

   for (int i = 0; i < n; i++) {

       int temp = table[i][0];

       table[i][0] = table[i][maxColumn];

       table[i][maxColumn] = temp;

   }

   // Виведення зміненої таблиці

   printf("Результат:\n");

   for (int i = 0; i < n; i++) {

       for (int j = 0; j < m; j++) {

           printf("%d ", table[i][j]);

       }

       printf("\n");

   }

   return 0;

}

У цій програмі спочатку вводяться розміри таблиці (n - кількість рядків, m - кількість стовпців), а потім вводяться елементи таблиці. Далі знаходиться максимальний елемент та його стовпець. Потім відбувається обмін першого стовпця і стовпця з максимальним елементом. На завершення виводиться змінена таблиця.

Важливо зазначити, що ця програма припускає, що розміри таблиці не перевищують максимальний розмір MAX_SIZE. Ви можете змінити цю константу відповідно до вашого потребу.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота