zakir2007
08.08.2022 02:56

Нужно сделать в паскаль авс самолет летит из пункта а в пункт б со средней скоростью v. составить программу для нахождения времени полёта t1, если есть встречный ветер, скорость которого v1, и времени t2, если ветра нет. расстояние между пунктами a и б считать известным и равным s.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
annmalik98
24.05.2020 23:02

var S, V, V1: real;

     t1, t2: real;

     b: boolean;

begin

  b:=false;

  repeat

    writeln('Введите расстояние между пунктами А и Б');

    readln(S);

    if S<0 then

      begin

        writeln('Отрицательное расстояние. Повторите ввод');

        continue;

      end;

    writeln('Введите среднюю скорость самолета');

    readln(V);

    if V<0 then 

      begin

        writeln('Отрицательная скорость. Повторите ввод');

        continue;

      end;

    writeln('Введите скорость встречного ветра');

    readln(V1);//Если ветра нет нужно ввести 0

    if V1<0 then

      begin

        writeln('Отрицательная скорость. Повторите ввод');

        continue;

      end;

    b:=true;

  until b = true;

  if V1>0

  then

    begin

      t2:=S/V;

      writeln('Время полета: ', t2);

    end

  else

    begin

      t1:=(V-V1)/S;

      writeln('Время полета: ', t1);

    end;

end.

 

   

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота