Mашka
27.09.2020 15:38

Дан целочисленный двумерный массив 6x10. опишите на языке и на языке программирования паскаль алгоритм вычисления произведения минимальных элементов из каждой строки. напечатать значение этого произведения. предполагается, что в каждой строке минимальный элемент единственный.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Bagila1234
30.06.2020 08:04
Ну в общих чертах проходиться по каждой строке массива, находить минимальный элемент и на него домножать результат.

uses crt;
const n=6;m=10;
var i,j,min,ans:integer;
a:array[1..n,1..m] of integer;
begin
ans:=1;
for i:=1 to n do
begin
for j:=1 to m do
begin
a[i,j]:=random(1,20);
write(a[i,j]:3);
end;
writeln;
end;
for i:=1 to n do
begin
min:=a[i,1];
for j:=2 to m do
if a[i,j]<min then
min:=a[i,j];
ans:=ans*min;
end;
writeln(ans);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота