Barbara123456
10.02.2021 07:29

Написать программу в pascalabc.net : с клавиатуры вводятся 3 числа.найти среднее арифметическое двух больших и двух меньших.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
trokhymukjulia
24.05.2020 23:11

по нубски правдо очень проверить не забудь)

var
a,n,c:integer;
x,y:real;
begin
readln(a);
readln(n);
readln(c);
if ((a > n) and (n > c)) then begin
x:=(a+n)/2;
y:=(n+c)/2;
end else if((n > a) and (a > c)) then begin
x:=(a+n)/2;
y:=(a+c)/2;
end else if((c > a) and (a > n)) then begin
x:=(a+c)/2;
y:=(a+n)/2;
end else if((c > n) and (n > c)) then begin
x:=(c+n)/2;
y:=(n+c)/2;
end else if((n > c) and (c > a)) then begin
x:=(c+n)/2;
y:=(a+c)/2;
end else if((a > c) and (c > n)) then begin
x:=(c+a)/2;
y:=(n+c)/2;
end else if((c > n) and (n > a)) then begin
x:=(c+n)/2;
y:=(n+a)/2;
end;
write('наибольшее: ',x,' наименьшее: ',y);
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота