Mariaxmxm
28.06.2020 12:09

Написать программу дан фрагмент: for n: =l to 6 do for m: =l to 5 do begin c[n,m]: =c[n,m]+(2*n-m); end; чему будет равно значение с[4,3], если перед этими значение с[4,3]=10? чему будет равно значение с[4,3], если перед этими значение с[4,3]=10?

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nastyacrew
30.06.2020 13:31
Во первых ошибка во фрагменте там должны быть цыфирки 1, а не буква l

 т.е   for n:=1 to 6 do
        for m:=1 to 5 do begin

Текст программы
Uses crt;
var c:array[1..6,1..5] of integer;
    n,m:integer;   
begin
      с[4,3]:=10;
    for n:=1 to 6 do
       for m:=1 to 5 do begin
        с[n,m]:=с[n,m]+(2*n-m);
         if (m=5)then
        writeln(c[n,m])
        else write(c[n,m],'  ');
        end;
     writeln;writeln;
     write('C[4,3]=',C[4,3]);
    readkey;
end.

Прогоночный вывод

1 0 -1 -2 -3
3 2  1 0 -1
5 4 3 2 1
7 6 15 4 3
9 8 7 6 5
11 10 9 8 7

Отсюда получаем что если с[4,3]:=10 перед началом цикла то с[4,3]=15
в противном случае с[4,3]=5
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота