rostislavcapsu
28.01.2020 23:06

Pascal (паскаль составить программу сортировки массива методом пузырька но не использовать for только через repeat + использовать flag всего в программе должно быть 3 переменных: i,flag,b: integer; заранее , тому кто свяжусь и отдельно

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Маша5411
30.06.2020 16:30
Program test;
const n = 5;
var i,flag,b:integer;
m:array [1..n] of integer;
begin
b:=1;
for i:=1 to n do
readln(m[i]);
repeat
b:=b+1;
if m[b]<m[b-1] then
begin
flag:=m[b-1];
m[b-1]:=m[b];
m[b]:=flag;
b:=1;
end;
until b=n;
for i:=1 to n do
writeln(i,')',m[i]);
end.

P.S. я использую for только для записи и вывода
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота