y4enik5
13.03.2020 18:27

Написать программу, которая вводит с клавиатуры одномерный массив из n целых чисел, после чего выводит нулевые элементы с их индексами (их можно и не оказаться) нужно написать программу на c++ используя обращения 1) по индексу и 2) по указателю.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Дженнет2001
01.07.2020 01:26
#include <iostream>
#include <ctime>
using namespace std;
int main ()
{ srand (time(NULL));
short N;
cout << "N=";
cin >> N;
int *array=new int [N];
cout << "Random array: ";
for (short i=0;i<N;i++)
{
array[i]=rand()%21-10;
cout << array[i] << ' ';
}
cout << endl;
for (short i=0;i<N;i++)
{
if (array[i]==0)
cout << "Nulls: " << array[i] << "(index=" << i << ')' << ' ';
}
system ("PAUSE>>VOID");
return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота