КириллПос
12.01.2022 17:53

Требовалось написать программу которая решает уравнение а|x|=b относительно х для любых чисел а и b, введенных с клавиатуры

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vova25051
01.07.2020 22:20
Var a,b:integer; x:real;
begin
readln (a,b);
x:=abs(b/a);
writeln (x:0:2);
end.

АБС это модуль, но я могу и ошибаться, тогда
var a,b:integer; x:real;
begin
readln (a,b);
If a<0 then a:=a*(-1);
If b<0 then b:=b*(-1);
x:=abs(b/a);
writeln (x:0:2);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота