vladishe1
14.05.2022 09:17

Написать программу, которая проверяет, является ли введенная с клавиатуры строка целым числом

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
рус248
02.07.2020 13:19
VAR
   s: String;
   i: LongInt;
BEGIN
   Read(s);

   for i := 1 to Length(s) do 
      if not((Ord(s[i]) > 47)and(Ord(s[i]) < 58)) then begin
      Write(s,' - не является целым число'); Exit; 
   end;

   Write(s,' - целое число'); 
END.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота