ruslanchik1999
04.12.2021 17:02

Спрограммой, ! нужно написать программу, которая по вводу с клавиатуры последовательности целых чисел (признак окончания ввода- ввод числа 0) подсчитывает среднее арифметическое нечетных чисел и чисел, кратных 5.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Котполиглот
02.07.2020 18:03
Var
   A,i:integer;
   B:real;
Begin
repeat
Writeln('Введи число.');
ReadLn(A);
if (A mod 10 =0) then
 Begin
  i:=i+1;
  B:=A+B;
 End;
until (A=0);
WriteLn('Среднее арифметическое нечетных чисел кратных 5 равно: ',B/(i-1));
ReadLn
End.
0,0(0 оценок)
Ответ:
berikkanovbekzat
02.07.2020 18:03
Var x,i:integer;
   y:real;
Begin
writeln('Признак окончания ввода - ввод числа 0');
repeat
Writeln('Введите число');
ReadLn(x);
if (x mod 2 >0) and (x mod 5 = 0) then 
Begin  i:=i+1; 
 y:=x+y; 
End;
until (x=0);
WriteLn('Среднее арифметическое нечетных чисел кратных 5 = ',y/i);
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота