6г56г
09.05.2022 07:32

Составить программу на паскале.вычислить корни квадратного уравнения, заданного коэффициентами a, b, c (предполагается, что а< > 0 и что дискриминант уравнения неотрицателен)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
cool107
05.07.2020 11:27
Var   a,b,c,D,x1,x2:real;
begin
write('Введите коэффициенты a, b, c: ' );
readln(a,b,c);
D:= b*b-4*a*c; 
if D>0 then 
   begin
   x1:=(-b-sqrt(D))/2/a;
   x2:=(-b+sqrt(D))/2/a;
   writeln('Два корня: ',x1,' и ',x2)
   end;
if D=0 then
   begin
   x1:=-b/2/a;
   writeln('Один корень: ',x1)
   end;
if D<0 then writeln('Корней нет')
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота