123456qwe1234567
04.04.2020 10:17

Составить программу ,находящую кол-во и сумму цифр пяти данных целых чисел ,используя процедуру

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
saralis
05.07.2020 12:13
Var i,x,k,s:integer;

function Sum(x:integer):integer;
var
   t:string;
   i:integer;
begin
s:=0;
t:=IntToStr(x);
for i:=1 to length(t) do s:=s+StrToInt(t[i]);
result:=s
end;

function Kol(x:integer):integer;
var t:string;
begin
t:=IntToStr(x);
result:=length(t)
end;

begin
for i:=1 to 5 do
  begin
  write('Введите число ',i,': '); 
  readln(x); 
  k:=Kol(x); 
  s:=Sum(x); 
  writeln('Количество цифр ',k,'; сумма цифр ',s)
  end
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота