Жан041
12.05.2021 02:17

№109. написать программу, которая вводит с клавиатуры 5 дробных чисел и вычисляет их среднее арифметическое.рекомендуемый вид экрана во время работы программы ниже. данные, введенные пользователем выделены полужирным шрифтом.вычисление среднего арифмитического последовательности дробных чисел. после ввода каждого числа нажимайте . -> 5.4 -> 7.8 -> 3.0 -> 1.5 -> 2.3 среднее арифмитическое введенной последовательности: 4. 00 для завершения работы программы нажмите < enter> .

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
SvinkaPeppa777
25.05.2020 04:26

#include <iostream>

using std::cin, std::cout, std::endl;

int main(){

   long double sum = 0;

   for(size_t i = 0;i<5; ++i){

        cout   << "-> ";

        double a;

       cin >> a;

       sum+=a;

   }

 cout << sum/5 << endl;

   return 0;

}

Но не вовсем понятно, что нужно делать после ввода каждого числа, я написал, что нужно вводить <Enter> после каждого

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота